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The Virtual Developer Bench

The Virtual Developer Bench is the developer’s opportunity to engage directly
with the Sabre experts who know their product inside and out. 

By the end of today’s call you will:

• Know how to install the SDK

• Understand IDE preparation

• Have viewed how to create a project structure for a Red App

• Know how to run/debug your project
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Sabre Red 360 is responsible for an entire ecosystem involving Travel technology producers and 
consumers, through its innovative Red App Marketplace and Developer network. 

Red App ecosystem overview

Travel Agencies
Travel Management companies
Leisure operators

Technology Providers Sabre Red 360 Technology Consumer

Apply Build Certify Publish Market

from Idea to Published Product

Red App Certified Developer
Private Agency Developer
Developer Partner

Red App Developers

Development Environment
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Sabre Red 360 & customization

• Sabre Red 360 is an end-to-end sales workspace that 
sells billions in Travel inventory each year. Could be 
extended by plugging-in modules, or Red Apps.

• Sabre Red 360 main View, offers advanced visualization 
capabilities and orchestration to the Travel consultant 
workflow. 

– Workflow, from Sabre Red 360 core, any business operation involved 
on SHOP, SELL, BOOK, TICKET and MANAGE RESERVATIONS of 
FLIGHT, HOTEL, CAR, CRUISE AND RAIL

• Sabre Red 360 Desktop App,  it is a multi-windowed 
workspace application,  which hosts Sabre’s main view, 
complimentary user workflows and allows integrations 
with back-office and external systems.

• Sabre Red Web, Mobile design brings (big) part of sales 
workspace to Travel Consultant’s pocket, or an internet 
café anywhere.
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Powered by Sabre Red Apps

Red App is a software package, created with Sabre Developer Tools, which bundles 
different extensions to customize Sabre Red 360 operations during runtime. 

Workflow extensions, allow access to 
data and controlled execution of 
Business operations done through 
Sabre Red 360 main View

Communication Foundations, allows 
Red Apps to access Sabre Red 
Platform Services exposed through 
SR 360 runtime and abroad

Tools and Utilities, general utility 
layer, allows to deal with user settings 
and authentication, as well 
integration with external systems and 
process automation.

Contributions to the User Interface, 
allows Red Apps to customize the 
Travel consultant workspace 
(Eclipse) or the primary Sabre Red 
360 UI (NGV)

SHOP, PRICE BOOK SELL TICKET MANAGE

Air, Hotel
Exchange
Hotel Details

Air, Hotel Air, Hotel, Car
Passive Add

Air End PNR
Modify PNR
Queue Place

UI Widgets Workflow Web Browser Workspace

Pop-up Forms
Tile Widgets
Command button + 
Popover
React bootstrap

Workflow panel button
Nudge
Add to PNR form
Refresh PNR
Interstitial

CrossWindow
WebKit View / Editor
Javascript API

View / Editor window
Red App Sidebar
Workspace Menus
Notifications
Modal Dialog

Sabre APIs Sabre Commands Web Active Listening Security

REST and SOAP API 
calls
GetReservation

Execute Sabre 
Commands
LLS Calls - HOST

HTTP Request EMU_RESPONSE Event
EMU_COMMAND 
Service

SSO Assertions

Agency Support Workspace

Agent Profile
Config Services

Log services
First run

Plugin resources
Internationalization

- Red App bundles could be provisioned to SR 360 through 
Sabre Red App Centre, using 2 distinct business models:

- Private Agency Red Apps, for limited distribution inside 
the Travel agency where it was developed. 

- Public Red Apps, which are marketed through Sabre Red 
App center, a B2B Marketplace where Travel agencies 
could navigate and purchase Red Apps from different 
Travel Technology and Content Providers.
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Sabre Red 360 SDK
• Who are Red App developers ?

– A Red App Certified Provider is a developer who is approved by Sabre. After Sabre 
approves a developer and their proposal, the developer can start creating a Red App

– Sabre developers require Sabre PCC + Agent ID on CERT environment, if you don’t 
have access to the credentials, please contact your Agency Admin.

• Complete solution to build, test and publish Red Apps

– Development Environment

• Web SDK – Storefront, Web Developer Tools + Sabre Concierge Tool

• Java SDK - Back office, workspace Integration, Eclipse IDE + Java

– Idea to Product workflow

• Apply, submit your idea

• Build and Test source code using Development Environment

• Generate Red App bundle and submit to beta test and certification process 
(CERT and PROD environments)

• Publish your Red App on the B2B marketplace

• Patch defects and release new features

– Help and Resources, developer community

• Sabre Red App Centre – upload , certify and publish your Red App. Manage user 
messaging and sales operations.

• Sabre Dev Studio – developer portal, access SDK and API documentation, read 
blog posts and get up to date on latest Industry and Tech trends.

• Online community – leverage Developer community, access sample codes and 
tutorials.

Apply Build Certify Publish Market

from Idea to Published Product

Red App Certified Developer
Private Agency Developer
Developer Partner

Red App Developers

Development Environment
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Streamline Travel Consultant workflows

• Who are potential users of a Red App ?
– Travel agencies, travel management companies, leisure operators, 

over 370,000 agents in 135 countries, most of whom use the Sabre 
Red 360.

• How Red Apps are marketed and provisioned for end 
users?
– The Sabre Red App Centre is the world’s first B2B app marketplace for 

the travel industry, where agents can shop and request Red Apps that 
they can use to extend the capabilities of their Sabre Red 360

• Shop Red Apps that extend the power of SR 360

• Order your Red App in the Sabre Red App Centre

• Activate your Red App using Admin tools

Travel Agencies
Travel Management companies
Leisure operators
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Developers  Resources & Downloads

Setup Development Environment

Build and Debug Red Apps

Bundle and Publishing procedures
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Developers  Resources & Downloads

Visit developer.sabre.com, Sabre’s Developers Portal

Head over to Sabre Red 360 SDK section, familiarize with help, getting started and resources areas

Download the SDK

Released monthly, Available on PC / Mac platform

Sabre Concierge Tool

Sabre Red 360 Target Platform

Red App Developer tools for Eclipse IDE

Sample Red App projects

SDK Documentation

Download any other necessary tools and apps

Eclipse IDE, Java runtime

Sabre Red 360 CERT / PROD Installers

Chrome Browser with access to Developer Tools

Visual Studio Code



go to developer.sabre.com , choose PRODUCT CATALOG menu, then SDK - Sabre Red 360



landing page for Sabre Red 360 SDK



access to online documentation



everything you need to start creating Red Apps



Navigate to Red App developer resources page, download SDK distribution file and any pre-requisite according 
to your platform, PC or Mac.



Prepare a folder with downloaded resource files, then let’s begin installing Development environment…
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Developers  Resources & Downloads

Setup Development Environment

Build and Debug Red Apps

Bundle and Publishing procedures
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Setup Development Environment

Java SDK + Eclipse IDE, a framework used to build Red Apps which are based on the 
Eclipse RCP specification, coded using Java language and extensions to the Eclipse 
workspace manager.

Web SDK, framework used to build Web Modules, or Web Red Apps, which are 
customizations that applies to Sabre Red 360 Next Generation View (NGV)
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Setup Development Environment

Java SDK + Eclipse IDE

Unpack and run Eclipse IDE

Configure Target Platform

Configure Eclipse run/debug settings

Configure Red App Tools



create a folder for Eclipse IDE and unpack downloaded file



Eclipse IDE does not require installation, after unpacked just locate and run the application



Define a folder where Eclipse IDE will save your development workspace, then hit Launch to start the IDE.



with Eclipse IDE you can code, test and deploy Sabre Red 360 Red Apps, lets add SDK files and configure the 
target platform.



Select window->preferences menu (on macOS select Eclipse->Preferences....)



You can type Target platform on the filter field on navigate to plug-in Development->Target Platform section, 
then under Target definitions section select Add... button to create a new definition



Select Nothing: Start with an empty target definition on the wizard dialog, hit next 



Name your Target platform ex.: Sabre Red 360 developer runtime, on the Locations tab hit Add.... button



Under Add Content pop-up select Directory and then Next



Hit Browse... button to open file explorer



locate the Directory where you extracted the SDK files



then select targetplatform folder



and hit the Select Folder button



back to the Add Directory pop-up hit Finish button



you should see the folder added to the locations list and a number a plug-ins available



now move to the Environment tab and configure settings according to your operating system, for windows 
select x86 under Architecture, for mac this step can be left with default values. 



Target platform is set up, just click on Finish button



Then make sure the new Target definition is selected on the list and hit Apply and Close button



Ok, now let’s configure Sabre Red 360 development runtime, Select Run->Run Configurations... menu



Select Eclipse Application from the available options, then hit the New icon on the toolbar



a new Configuration will be created with default values, give it a name, like Sabre Red 360 runtime, under 
Program to Run section, select Run a product then com.sabre.edge.app.product from the dropdown



on the Java Runtime Environment, select Runtime JRE and then hit Installed JREs... button on the right side



On the Installed JREs pop-up, hit Add... button



now from the JRE Type pop-up, select Standard VM and hit Next > button



hit the Directory.... button, on the right side of JRE Home field



now point the explorer window to the directory where you downloaded the JRE files



Select root directory of the Java runtime folder, then hit Select Folder button



once JRE home is selected, hit the Finish button



now make sure the JRE definition that you created is selected and hit Apply and Close button



now back to the Java Runtime Environment section, just select the newly create JRE definition under the 
Runtime JRE dropdown field



now let’s select the Arguments tab from the Run configuration, and add few instructions to the VM Arguments 
field :
-Xms128m
-Xmx1024m
-Dosgi.parentClassloader=ext
-Ddynamo_testing_remote_debugging=true
***for macOS please check Use the -XstartOnFirstThread field below VM Arguments.



now on the Plug-ins Tab, you can control which plugin should be loaded during runtime, this includes RedApp
projects on the Eclipse workspace, which you can selectivelly choose to run or not, and also the Target 
platform files, which should be all... it good idea to hit the Validate plug-ins button just to make sure its all right



Run confifguration is complete, for now let’s do a test run on Sabre Red 360 Development mode under CERT 
environment, hit Run button



and you should see Sabre Red 360 sign-in dialog, enter your CERT credentials and hit Sign In button



a minute or so and you should see Sabre Red 360 Desktop running with all Red Apps present on the Run 
Configuration.



Select Help->Instal new Software menu, then hit the Add... button to the right of the Work with: field



on the Add Repository pop-up, give it a meaningful name, like Red App tools, and hit the Archive... button 



on the file explorer, navigate the the directory where you extracted SDK files, and locate / select the devtools
folder, after that hit the Add button and you should see a list of available tools to install



select desired developer tools (or all) and hit the Next > button



Acknowledge the license fields and hit Next > to continue



After installation is complete a pop-up will appear and Eclipse restart is required, well done, installation of 
Eclipse IDE is complete.
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Setup Development Environment

Web SDK, framework used to build Web Modules, or 
Web Red Aps, which are customizations that applies to 
Sabre Red 360 Next Generation View (NGV)

Install or upgrade Sabre Concierge Tool
install Web Development Tools (3rd party, optional)



Locate the folder where you extracted SDK files



Open SDK main folder (named red-app-sdk[version])



navigate to webmodules subfolder



then tools



Locate the ConciergeInstaller executable (.jar file on macOS)



Run Sabre Concierge installer
*** It's recommended to run installer with Administrator rights, given it needs permission to create symbolic links and directories, it may fail 
otherwise.



select destination folder to install NodeJS, NPM and Sabre Concierge tool.
*defaults to Program Files on the PC, but depending on the netowrk / user policies it would be recommended to left it out of Program files to 
avoid permission issues (like C:\Dev\RedApps\Concierge)



confirm Directory creation



and packages to install then hit Next button



NodeJS and NPM are installed by default



then Sabre concierge files are copied and validated through NPM (Node package manager), this may take few 
minutes, good opportunity for a coffee break...



This process may take several minutes, but there is no user intervention needed



Files copied, hit Next button to start post copy procedures



Post installation procedures, configures NodeJS and  adds Sabre Concierge run command, NGV, to the system 
path, then SABRE_CONCIERGE Typescript package is bound to the system and ready to be referenced during 
Web Red Apps development.



wait for SUCCESS message on installer log window, hit Next when available to finish installation procedure.



you are done with Concierge Installer



to validate installation open Command Prompt or Terminal window and type NGV --version command, it 
should echo the version of Sabre Concierge Tool just installed



Now let’s install Visual Studio code, as optional Editor for Web Modules, using Typescript language



Just start installer App and follow instructions on the screen



Choose additional tasks as desired



Visual Studio Code files are copied



Then setup is finished
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Developers  Resources & Downloads

Setup Development Environment

Build and Debug Red Apps

Bundle and Publishing procedures
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Build and Debug Red Apps

Build Red Apps Basic Red App project structure

Run / Debug Red Apps
Sabre Red 360 Desktop

Sabre Red Web



on Eclipse IDE, select Create a new plug-in project using Project Explorer, or through File->New->Plug-in Project



Plug-in Projects are quite at default values, here special attention to Project Name, which is recommended to 
use reverse domain notation like com.yourdomain.yourapp and reply same name in the ID field following



under plug-in Properties: 
ID : uniquely identifies a plug-in, hence usage of reverse domain notation to avoid duplicates
Version : Major.Minor.Patch.qualifier format
Name: Red App comercial name, same as registered under Red App proposal
Vendor: Red App provider as registered on development agreement.
*** Generate an activator check is required for Java / Sabre Red 360 Desktop only Red Apps, optional for Web Red Apps



feel free to choose add-ons for your project, or just hit Finish to complete project structure creation



on the Project Explorer Tab, locate the MANIFEST.MF file, and double click to open with Manifest Editor, on the 
Overview tab, make sure to check This plug-in is a singleton field



Dependencies tab, you can hit add button and navigate through ones "shared" from the Target platform and 
SDK, lets add minimally required :
com.sabre.edge.redapp.contactdetails, com.sabe.edge.cf.core, com.sabre.edge.platform.core.common



Extension tab, hit Add... button to configure new extension for your plug-in



minimal required are com.sabre.edge.cf.redapp and com.sabre.edge.redapp.contactdetails.provider



plug-in extensions are stored on plugin.xml file on your project, you can check it on Manifest editor tab



now let's add a new file to the project root, select File->New->File from menu, or right click project name on 
explorer and use contextual menu



name the file redapp.xml and make sure to save it on the project root level, same as plugin.xml



All Red Adds must expose a redapp.xml file with mandatory element containing the Red App ID for your 
project, the RedAppID is given when Red App proposal is approved through Sabre Red App centre.
***You can start building your Red app and running within Eclipse target platform without a definitive RedApp ID / proposal , just set it as 22 
random numbers.



Now that we created our bare-minimal Red App plug-in, let's take a look on the Activator class and get 
familiarized with its code and functionality 



First let's change Interface implemented by Activator class, this will allow Red App to achieve greater 
connectivity with Sabre Red 360 Runtime engine, as well Services exposed through SDK, make sure Activator 
Class Extends AbstractEdgeBasePlugin



Now our Red App plugin project structure is ready to be used and loaded into Sabre Red 360 during 
development stage
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Build and Debug Red Apps

Build Red Apps Web Module project structure

Run / Debug Red Apps
Sabre Red 360 Desktop

Sabre Red Web



let's create a folder to hold Web Module source code, select File->New->Folder menu



by convention , Web Module folder should be named web-src, and added to the Eclipse project root



now let's add a new Extension to the plug-in to inform that it carries a Web Module within, double click on the 
MANIFESTMF file to bring up the Manifest Editor screen, then select Extensions tab and hit Add... button



On the Extension Point selection pop-up, type Web to filter available options, then select 
com.sabre.edge.dynamo.web.module extension and hit Finish button



back to the Manifest editor screen, select the Web module extension just created and fill up its ID, this will be 
same as plug-in ID, but with points replaced by dashes and a web-module postfix 



you can validate or edit the extension details by opening the plugin.xml file as well



now let's create the Web Module structure inside web-src folder, for that we will be using Sabre concierge tool, 
which is driven by Command Prompt / Terminal commands, right click on the web-src folder and hit Show In-
>System explorer



we want to copy the complete path of the web-src folder to the clipboard



now open a Command Prompt window (or Terminal on mac), then change directory to the one you just copied 
on previous step, the web-src folder



once there, enter NGV init command, that will create the Web Module structure inside the folder



fill up the project information, similarly as you did with Eclipse pug-in creation :
Bundle Symbolic Name:  A unique name that identifies your Red App bundle, use Reverse domain notation like (com.yourdomain.redappname)
Project Author: Who is writing the code
The contact detail as registered where Developer account was created :
E-mail, Phone, Company Name, Contact Person
Bundle Name: Name of  your Red App as by the proposal submitted (case sensitive)
Website: Developer website address
RedApp ID: (if you don’t have it at hand fill up with 22 number sequence)



NGV init process will now create files and folders under web-src folder, expect a SUCCESS message at the end 
of process



you can inspect the folders and files created, also identify the "root" of the Web Module project, where 
package.json files resides, there's where you need to issue any additional Concierge command



back to Eclipse IDE, just right click on web-src folder and hit Refresh (or F5) to show newy created files, From 
now its matter of preference, we recommend using Visual Studio code to build your Web Red Apps, but you 
also may have other developer tools like InteliJ or add-ons to the Eclipse IDE that suits well Web development 
languages.



Open Visual Studio code, and then select File->Open Folder..., and then select the Web Module root folder just 
created



To be able to run your Web Module using Sabre Red 360 Desktop and Eclipse IDE, you need to create a 
concierge.conf.js on the root of WebModule folder, and add the information above, this will copy all Web 
Module files during build process to the web folder, which will be used during runtime to serve the WebModule



Get familiar with Web Module project structure, special attention to the Main.ts file, which is initialized during 
Sabre Red 360 startup. 



Now lets "compile" our Web Module project, for that open a new terminal window on the root of the Web 
Module project, we can use Visual Studio Code integrated terminal, select Terminal->New Terminal menu



on the command prompt enter NGV build command, this will "compile" the Typescript source code into 
JavaScript, which will be used at runtime by Sabre Red 360



Now you should be able to test run your Red App and the Web module, here you have freedom to choose which 
environment to run with, Sabre Red 360 Desktop (Eclipse) or Sabre Red Web (Web Browser)...
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Build and Debug Red Apps

Build Red Apps
Basic Red App project structure

Web Module project structure

Run / Debug Red Apps Sabre Red 360 Desktop



On Eclipse IDE, select Run->Run or Debug menu



After few seconds you should see Sabre Red 360 sign-in dialog, enter your CERT credentials and hit Sign In 
button



After Sabre Red 360 loads, you can validate that your Red App plug-in is loaded by selecting Contact Us-
>Application Vendor Support menu



this will display all loaded Red App, including version / contact details for each one



for debugging Web Modules, we use an embedded Chrome Browser from Sabre Red 360 desktop, for that 
select Tools->Other->Browser Debug Tool menu on the Sabre Red 360 menu bar.



Browser debug tools will list all available pages to inspect / debug, in the case you will select Sabre Red 360 
file



this will open Chrome developer tools panel, with access to the JavaScript console and other utilities to help 
build and debug your Web Module.
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Build and Debug Red Apps

Build Red Apps
Basic Red App project structure

Web Module project structure

Run / Debug Red Apps Sabre Red Web



to run a Web Module Red App on a Browser, you need to create a server that will "host" the plug-in, so it can be 
loaded on the developer instance of Sabre Red Web, for that open a Command prompt window at root of the 
Web Module project and issue a NGV run command.



you should expect a READY message on the console, as well a localhost address that will be used to load the 
Web Module, copy it to the clipboard (note that you can have more than one server to host Web Modules, for 
that you need to inform different port number for the NGV run command.)



Open you Web Browser and point to SRW.CERT.SABRE.COM, this will load Sabre Red Web and prompt for 
CERT credentials



We can turn on browser developer tools, so we have access to console and tools to debug your Web Module



Now hit the jigsaw icon on the right sidebar or Sabre Red Web, this is the development mode tools that let you 
load Web Modules dynamically during runtime, if you don't see this button on your Sabre Red Web instance, 
please contact your Account Manager or Red App support team.



Once Red App Development pop-up is shown, enter the URL for the Web Module host (default is 
http://localhost:8080), and hit the + (Plus) button to the right side on the field



then hit Apply button, which will re-load Sabre Red Web and the Web Modules added through this panel



You can validate successful load of the Web Module by the green color on the jigsaw icon, or just by locating 
Web Module ID on the console log.
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Developers  Resources & Downloads

Setup Development Environment

Build and Debug Red Apps

Bundle and Publishing procedures
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Bundle and Publishing procedures

Bundle

Red App tools added to Eclipse IDE allows Exporting Red App bundles with 
Wizard style interface.

Sabre Concierge Tool is used to create the Red App bundle, NGV EXPORT 
command would do the trick.

Red App bundles needs to be signed with Application Certificate issued to 
Red App provider (Developer) 

Publishing
Upload Red App bundle and Documentation to Sabre Red App Centre

Perform beta test and certification process

Manage Red App Storefront



Let's create a bundle, which is a compressed file containing the Red App plug-ins that would be sent for 
certification and finally provisioned to the userbase. Select File->Export... from the Eclipse menu.



Red App developer tools installed previously offers a Wizard style interface to generate Red App bundles. 
Select Red App Development -> Red App Bundle from the available export choices, then hit Next button.



Red App Bundle export pop-up is shown, select the Red App plug-in project to be exported and a directory 
where the generated file would be saved. Notice that to create a Red App bundle, the file must be digitally 
signed too proof authenticity of the Red App and Provider, this is done through a Java Application certificate 
issued by Sabre's approved authorities, please be sure to acknowledge on that requirement with Red App 
support team or your Account Representative.



Select the Main plug-in for the Red App, that's the package which implements the Activator class



you should have a file created at specified location, this will be uploaded through Sabre Red App Centre 
developer panel for certification and publishing
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Step by step guide about installation procedures and creation of Red App project

Getting started with Red App Software Developer Toolkit

Bundle and Publishing procedures

Bundle

Red App tools added to Eclipse IDE allows Exporting Red App bundles 
with Wizard style interface.

Sabre Concierge Tool is used to create the Red App bundle, NGV EXPORT 
command would do the trick.

Red App bundles needs to be signed with Application Certificate issued to 
Red App provider (Developer) 

Publishing
Upload Red App bundle and Documentation to Sabre Red App Centre

Perform beta test and certification process

Manage Red App Storefront



Open a Web Browser and navigate to https://www.sabreredappcentre.sabre.com



Enter you developer credentials provided upon Developer agreement with Sabre.



Navigate to My Red Apps -> Developed , using the Sidebar menu on the Admin view of Red App Centre, locate 
the App which you want to manage and hit View More button on the Action column



Here you can see your Red App details, manage front page and get usage reports, also publish bundles and 
submit certification assessments when required. On that case we are submitting new bundle (or patch, given 
we already have a previous version published. Hit Submit button undr Submit new Bundle section.



Then just select the bundle file exported previously and a doc or pdf file containing detailed instructions on 
how to test the Red App according to use case. It may require other documents depending on the Red App 
features, as for PCI / PII and Security compliance if needed.



once successfully submitted your bundle will be automatically validated and sent through Certification process



Certification is a multi-stage process involving developer, Sabre engineers and optionally beta customers 
which ensure the quality over the published Red Apps, once all approved it is finally available for purchases 
and provisioning at Travel consultant's workspace.




